source: abuse/trunk/INSTALL

Last change on this file was 609, checked in by Sam Hocevar, 7 years ago

build: allow to specify --disable-nonfree to avoid installing non-free data
and build stripped down tarballs.

File size: 997 bytes
Line 
1Requirements for compiling
2--------------------------
3
4- SDL 1.1.6 <http://www.libsdl.org>
5- SDL-Mixer
6- GL libraries and headers are required for OpenGL support.
7
8
9Compiling
10---------
11
121. Untar the abuse-x.x.tar.gz file.
13
14     tar xzf abuse-x.x.tar.gz
15
16   This will create an abuse-x.x directory with the source in it.
17
182. Run  './configure'
19   This will create the Makefiles required to build Abuse.
20
21   If you wish to specify a location for the datafiles instead of using the
22   default of '/usr/local/share/games/abuse', you can do so by passing the
23   following argument to the configure script:
24
25     --datadir=<location>
26
27   where <location> is the directory where the datafiles will be installed.
28
293. Run  'make'
30   This will start the build.
31
324. Run 'make install'
33   This will install Abuse.
34
35
36Mac OS X
37--------
38
39A Project Builder project is included in the 'osx' directory and can be used
40if desired.  Using project Builder is currently the only way to get OpenGL
41support compiled in.
42
Note: See TracBrowser for help on using the repository browser.