source: abuse/tags/0.7.1/INSTALL @ 69

Last change on this file since 69 was 2, checked in by Sam Hocevar, 13 years ago
  • imported original 0.7.0 tarball
File size: 1.2 KB
Line 
1Requirements for Compiling
2--------------------------
3- SDL 1.1.6 <http://www.libsdl.org>
4- X11R6(or above) and libraries.
5- Linux kernel 2.2 or above.
6- GL libraries and headers are required for OpenGL support.
7
8
9Compiling
10---------
11
121. Untar the abuse_sdl-x.x.tar.gz file.
13
14     tar -zxf abuse_sdl-x.x.tar.gz
15
16   This will create an abuse_sdl-x.x directory with the source in it.
17
182. Run  './configure'
19   This will create the Makefiles required to build Abuse-SDL.
20
21   If you wish to specify a location for the datafiles instead of using the
22   default of '/usr/local/share/games/abuse', you can do so by passing the
23   following argument to the configure script:
24
25     --datafir=<location>
26
27   where <location> is the directory where the datafiles will be installed.
28
293. Run  'make'
30   This will start the build.
31
324. Run 'make install'
33   This will install Abuse-SDL.
34
35
36MacOSX
37------
38A Project Builder project is included in the 'osx' directory and can be used
39if desired.  Using project Builder is currently the only way to get OpenGL
40support compiled in.
41
42
43If anything goes wrong please contact me at <trandor@labyrinth.net.au> with
44the details, and I'll try and sort it out.
45
46Good luck,
47Anthony Kruize
Note: See TracBrowser for help on using the repository browser.